PU
Product
Puppet
by Puppetlabs · last CVE Mar 14, 2014
29
CVEs
0
On KEV
–
Max CVSS
0
New 30D
Severity mix
Critical 0High 0Medium 0Low 0
Watch

Add Puppet to your stack to get only the CVEs that touch what you run.

CVECVSSEPSSPublishedSummary · affected versions
CVE-2013-1399
–
1%
Mar 14
Multiple cross-site request forgery (CSRF) vulnerabilities in the (1) node request management, (2) live management, and (3) user administration components in the console in Puppet…
Affected: 2.5.0; 2.6.0
CVE-2013-1398
–
2%
Mar 14
The pe_mcollective module in Puppet Enterprise (PE) before 2.7.1 does not properly restrict access to a catalog of private SSL keys, which allows remote authenticated users to…
Affected: 2.5.0; 2.6.0
CVE-2012-5158
–
1%
Mar 14
Puppet Enterprise (PE) before 2.6.1 does not properly invalidate sessions when the session secret has changed, which allows remote authenticated users to retain access via…
Affected: 2.5.0
CVE-2013-4969
–
0%
Jan 7
Puppet before 3.3.3 and 3.4 before 3.4.1 and Puppet Enterprise (PE) before 2.8.4 and 3.1 before 3.1.1 allows local users to overwrite arbitrary files via a symlink attack on…
Affected: 3.0.0 through 3.3.2; 3.4.0 before 3.4.1
CVE-2013-4956
–
0%
Aug 20
Puppet Module Tool (PMT), as used in Puppet 2.7.x before 2.7.23 and 3.2.x before 3.2.4, and Puppet Enterprise 2.8.x before 2.8.3 and 3.0.x before 3.0.1, installs modules with weak…
Affected: 2.7.0; 2.7.1; 3.2.0
CVE-2013-4761
–
2%
Aug 20
Unspecified vulnerability in Puppet 2.7.x before 2.7.23 and 3.2.x before 3.2.4, and Puppet Enterprise 2.8.x before 2.8.3 and 3.0.x before 3.0.1, allows remote attackers to execute…
Affected: 3.2.0; 2.7.0; 2.7.1
CVE-2013-3567
–
3%
Aug 19
Puppet 2.7.x before 2.7.22 and 3.2.x before 3.2.2, and Puppet Enterprise before 2.8.2, deserializes untrusted YAML, which allows remote attackers to instantiate arbitrary Ruby…
Affected: 2.7.0; 2.7.1; 2.7.19; 2.7.20; 2.7.20; 3.2.0; +8 more
CVE-2013-2716
–
1%
Apr 10
Puppet Labs Puppet Enterprise before 2.8.0 does not use a "randomized secret" in the CAS client config file (cas_client_config.yml) when upgrading from older 1.2.x or 2.0.x…
Affected: 1.0.0; 1.1.0; 1.2.0; 2.5.0; 2.6.0
CVE-2013-2275
–
3%
Mar 20
The default configuration for puppet masters 0.25.0 and later in Puppet before 2.6.18, 2.7.x before 2.7.21, and 3.1.x before 3.1.1, and Puppet Enterprise before 1.2.7 and 2.7.x…
Affected: through 2.6.17; 2.7.0; 2.7.1; 2.7.19; 2.7.20; 2.7.20; +1 more
CVE-2013-2274
–
3%
Mar 20
Puppet 2.6.x before 2.6.18 and Puppet Enterprise 1.2.x before 1.2.7 allows remote authenticated users to execute arbitrary code on the puppet master, or an agent with puppet kick…
Affected: 2.6.17
CVE-2013-1655
–
5%
Mar 20
Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, when running Ruby 1.9.3 or later, allows remote attackers to execute arbitrary code via vectors related to "serialized…
Affected: 2.7.0; 2.7.1; 2.7.19; 2.7.20; 2.7.20
CVE-2013-1654
–
3%
Mar 20
Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, and Puppet Enterprise 2.7.x before 2.7.2, does not properly negotiate the SSL protocol between client and master, which allows…
Affected: 2.7.0; 2.7.1; 2.7.19; 2.7.20; 2.7.20; 2.7.0; +1 more
CVE-2013-1653
–
5%
Mar 20
Puppet before 2.6.18, 2.7.x before 2.7.21, and 3.1.x before 3.1.1, and Puppet Enterprise before 1.2.7 and 2.7.x before 2.7.2, when listening for incoming connections is enabled…
Affected: 2.7.0; 2.7.1; 2.7.19; 2.7.20; 2.7.20; 1.0; +8 more
CVE-2013-1652
–
2%
Mar 20
Puppet before 2.6.18, 2.7.x before 2.7.21, and 3.1.x before 3.1.1, and Puppet Enterprise before 1.2.7 and 2.7.x before 2.7.2 allows remote authenticated users with a valid…
Affected: through 2.6.17; 2.7.0; 2.7.1; 2.7.19; 2.7.20; 2.7.20; +1 more
CVE-2012-3867
–
2%
Aug 6
lib/puppet/ssl/certificate_authority.rb in Puppet before 2.6.17 and 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, does not properly restrict the characters in the…
Affected: through 2.6.16; 2.7.0; 2.7.1
CVE-2012-3866
–
0%
Aug 6
lib/puppet/defaults.rb in Puppet 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, uses 0644 permissions for last_run_report.yaml, which allows local users to obtain…
Affected: through 2.7.17; 2.7.0; 2.7.1
CVE-2012-3865
–
2%
Aug 6
Directory traversal vulnerability in lib/puppet/reports/store.rb in Puppet before 2.6.17 and 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, when Delete is enabled in…
Affected: through 2.7.17; 2.7.0; 2.7.1; through 2.6.16
CVE-2012-3864
–
2%
Aug 6
Puppet before 2.6.17 and 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, allows remote authenticated users to read arbitrary files on the puppet master server by…
Affected: through 2.6.16; 2.7.0; 2.7.1
CVE-2012-3408
–
2%
Aug 6
lib/puppet/network/authstore.rb in Puppet before 2.7.18, and Puppet Enterprise before 2.5.2, supports use of IP addresses in certnames without warning of potential risks, which…
Affected: before 2.7.18
CVE-2012-1989
–
0%
Jun 27
telnet.rb in Puppet 2.7.x before 2.7.13 and Puppet Enterprise (PE) 1.2.x, 2.0.x, and 2.5.x before 2.5.1 allows local users to overwrite arbitrary files via a symlink attack on the…
Affected: 2.7.0; 2.7.1
CVE-2012-1986
–
1%
May 29
Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, and 2.5.x before 2.5.1 allows remote authenticated users with an…
Affected: 2.7.0; 2.7.1
CVE-2012-1906
–
0%
May 29
Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, and 2.5.x before 2.5.1 uses predictable file names when installing Mac…
Affected: 2.7.0; 2.7.1
CVE-2012-1054
–
0%
May 29
Puppet 2.6.x before 2.6.14 and 2.7.x before 2.7.11, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x before 2.0.3, when managing a user login file with the k5login resource…
Affected: 2.7.0; 2.7.1
CVE-2012-1053
–
0%
May 29
The change_user method in the SUIDManager (lib/puppet/util/suidmanager.rb) in Puppet 2.6.x before 2.6.14 and 2.7.x before 2.7.11, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x,…
Affected: 2.7.0; 2.7.1
CVE-2011-3872
–
3%
Oct 27
Puppet 2.6.x before 2.6.12 and 2.7.x before 2.7.6, and Puppet Enterprise (PE) Users 1.0, 1.1, and 1.2 before 1.2.4, when signing an agent certificate, adds the Puppet master's…
Affected: 2.7.0; 2.7.1
CVE-2011-3871
–
0%
Oct 27
Puppet 2.7.x before 2.7.5, 2.6.x before 2.6.11, and 0.25.x, when running in --edit mode, uses a predictable file name, which allows local users to run arbitrary Puppet code or…
Affected: 2.7.0; 2.7.1
CVE-2011-3870
–
0%
Oct 27
Puppet 2.7.x before 2.7.5, 2.6.x before 2.6.11, and 0.25.x allows local users to modify the permissions of arbitrary files via a symlink attack on the SSH authorized_keys file
Affected: 2.7.0; 2.7.1
CVE-2011-3869
–
0%
Oct 27
Puppet 2.7.x before 2.7.5, 2.6.x before 2.6.11, and 0.25.x allows local users to overwrite arbitrary files via a symlink attack on the .k5login file
Affected: 2.7.0; 2.7.1
CVE-2011-3848
–
1%
Oct 27
Directory traversal vulnerability in Puppet 2.6.x before 2.6.10 and 2.7.x before 2.7.4 allows remote attackers to write X.509 Certificate Signing Request (CSR) to arbitrary…
Affected: 2.7.0; 2.7.1
Showing 29