Critical severity · published Feb 2, 2026
CVE-2026-22778
vLLM leaks a heap address when PIL throws an error
9.8
CVSS
18.5%
EPSS
No
On KEV
Description
vLLM is an inference and serving engine for large language models (LLMs). From 0.8.3 to before 0.14.1, when an invalid image is sent to vLLM's multimodal endpoint, PIL throws an error. vLLM returns this error to the client, leaking a heap address. With this leak, we reduce ASLR from 4 billion guesses to ~8 guesses. This vulnerability can be chained a heap overflow with JPEG2000 decoder in OpenCV/FFmpeg to achieve remote code execution. This vulnerability is fixed in 0.14.1.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)18.5% · higher than 97% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
VL
vllm · vllm-project
>= 0.8.3, < 0.14.1 · source: vendor, NVD
RH
Red Hat AI Inference Server 3.2 · Red Hat
All versions, or not specified · source: CISA
RH
Red Hat AI Inference Server 3.3 · Red Hat
All versions, or not specified · source: CISA
RH
Red Hat Enterprise Linux AI (RHEL AI) 3 · Red Hat
All versions, or not specified · source: CISA
RH
Red Hat OpenShift AI 2.25 · Red Hat
All versions, or not specified · source: CISA
RH
Red Hat OpenShift AI 3.3 · Red Hat
All versions, or not specified · source: CISA
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-22778
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-22778
Issue Tracking
https://github.com/vllm-project/vllm/pull/31987
Issue Tracking
https://github.com/vllm-project/vllm/pull/32319
Release Notes
https://github.com/vllm-project/vllm/releases/tag/v0.14.1
Vendor Advisory
https://github.com/vllm-project/vllm/security/advisories/GHSA-4r2x-xpjr-7cvv
access.redhat.com
https://access.redhat.com/errata/RHSA-2026:19712
access.redhat.com
https://access.redhat.com/errata/RHSA-2026:30087
More from vllm
9.8
CVE-2026-115915
vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE
9.8
CVE-2026-25960
SSRF Protection Bypass in vLLM
9.8
CVE-2026-22807
vLLM affected by RCE via auto_map dynamic module loading during model initialization
9.8
CVE-2025-47277
vLLM Allows Remote Code Execution via PyNcclPipe Communication Service
9.8
CVE-2025-32444
vLLM Vulnerable to Remote Code Execution via Mooncake Integration
