Critical severity · published Oct 26, 2026
CVE-2026-115915
vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE
New
9.8
CVSS
0.6%
EPSS
No
On KEV
Description
vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.6% · higher than 50% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
VL
vllm · vllm-project
< 0.32.0 · source: vendor, NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-115915
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-115915
github.com
https://github.com/vllm-project/vllm/commit/710ac56e691d4713feca50a43e6c440f07d373fd
github.com
https://github.com/vllm-project/vllm/pull/60022
github.com
https://github.com/vllm-project/vllm/releases/tag/v0.32.0
github.com
https://github.com/vllm-project/vllm/security/advisories/GHSA-h3rc-j82p-2c3h
More from vllm
9.8
CVE-2026-25960
SSRF Protection Bypass in vLLM
9.8
CVE-2026-22778
vLLM leaks a heap address when PIL throws an error
9.8
CVE-2026-22807
vLLM affected by RCE via auto_map dynamic module loading during model initialization
9.8
CVE-2025-47277
vLLM Allows Remote Code Execution via PyNcclPipe Communication Service
9.8
CVE-2025-32444
vLLM Vulnerable to Remote Code Execution via Mooncake Integration
