Critical severity · published Oct 22, 2026
CVE-2026-111497
Out-of-Bounds Write in Google Brotli Decoder
In wildKEVNew
9.8
CVSS
55.5%
EPSS
Yes
On KEV
Description
A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream.
Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)55.5% · higher than 99% of CVEs
Exploited in the wildYes
CISA KEVListed Oct 27, 2026
Federal remediation dueNov 10, 2026
Ransomware campaign useNot known
Affected products
Which versions
BR
Brotli · Google
1.0.3 before 1.0.10; 1.1.0 before 1.1.1; 1.2.0 before 1.2.1 · source: vendor, NVD, KEV
NE
.net · Microsoft
8.0.0 before 8.0.33; 9.0.0 before 9.0.22; 10.0.0 before 10.0.14; 11.0.0; 11.0.0; 11.0.0; +6 more · source: NVD
7Z
7-zip-zstd · Mcmilk
through 26.02-1.5.7-r2 · source: NVD
AR
Arrow · Apache
through 26.0.0; 27.0.0 · source: NVD
BR
Brotlicffi · Python-hyper
before 1.2.1.0 · source: NVD
BU
Bun · Anthropic
before 1.4.4 · source: NVD
CL
Clickhouse · Clickhouse
through 26.10.2.103 · source: NVD
DL
Debian Linux · Debian
12.0 · source: NVD
DU
Duckdb · Duckdb
through 2.0.0 · source: NVD
ED
Edk2 · Tianocore
through 202608 · source: NVD
EN
Envoy · Envoyproxy
before 1.37.8; 1.38.0 before 1.38.6; 1.39.0 before 1.39.3 · source: NVD
IS
Istio · Istio
before 1.29.9; 1.30.0 before 1.30.6; 1.31.0 before 1.31.2 · source: NVD
In the news
VulnerabilityHigh
Waiting on a Node.js Upgrade? Build a Stopgap with the Controls You Own
Executive Summary Node.js has fixed CVE-2026-111497, a Brotli decoder flaw that can permit remote code execution, in 22.23.4, 24.22.1, and 26.12.1, but upgrading at scale is slow. In Qualys telemetry, only 42,000 of roughly 3 million Node.js installations have been patched, and 1.7 million run end-of-life lines that will never receive a fix. In the […]
Oct 28, 2026·Qualys Blog
VulnerabilityHigh
Brotli bug reaches far beyond Node.js (CVE-2026-111497)
A vulnerability in Brotli, Google’s widely used open-source compression library, is putting a broad range of software at risk. About CVE-2026-111497 Alternatively known as “Node2Shell”, “Broccoli2Shell” and “Brotli2Shell”, CVE-2026-111497 is a remotely exploitable out-of-bounds write flaw that gained widespread attention after Node.js publicly disclosed it on October 21, 2026. “An attacker who can supply Brotli data that an application decompresses with node:zlib can corrupt process memory, which can lead to a crash, disclosure of process … More →
The post Brotli bug reaches far beyond Node.js (CVE-2026-111497) appeared first on Help Net Security .
Oct 27, 2026·Help Net Security
AdvisoryHigh
CISA Adds Two Known Exploited Vulnerabilities to Catalog
CISA has added two new vulnerabilities to its Known Exploited Vulnerabilities (KEV) Catalog , based on evidence of active exploitation.
CVE-2026-48356 Adobe Commerce and Magento Unrestricted Upload of File with Dangerous Type Vulnerability
CVE-2026-111497 Google Brotli Unchecked Return Value Vulnerability
These types of vulnerabilities are a frequent attack vector for malicious cyber actors and pose significant risks to the federal enterprise.
Binding Operational Directive (BOD) 26-04: Prioritizing Security Updates Based on Risk establishes vulnerability management requirements for Federal Civilian Executive Branch (FCEB) agencies. BOD 26-04 reinforces the importance of the KEV Catalog and requires federal agencies to prioritize rapid remediation of high-risk vulnerabilities, specifically those identified by Common Vulnerabilities and Exposures (CVEs) listed in CISA’s KEV Catalog on publicly exposed assets that grant total control of the asset post-exploitation, while deferring action for lower-risk vulnerabilities. BOD 26-04 further establishes basic expectations for when agencies must check whether threat actors compromised the system before the patch was applied.
While BOD 26-04 applies only to FCEB agencies, CISA encourages all organizations to adopt risk-based vulnerability management and prioritize remediation of KEV Catalog vulnerabilities . CISA will continue to add vulnerabilities to the catalog that meet the specified criteria .&nb...
Oct 27, 2026·US-CERT Current Activity
VulnerabilityCritical
[CISA KEV] CVE-2026-111497: Google Brotli - Google Brotli Unchecked Return Value Vulnerability
Google Brotli contains an unchecked return value vulnerability that allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream.
BRBrotliCVE-2026-111497
Oct 27, 2026·CISA KEV
VulnerabilityHigh
PHP Issues Second Windows Security Update in Five Days to Fix Brotli Code Execution Flaw
PHP has rebuilt its official Windows packages for PHP 8.2 through 8.5 to fix CVE-2026-111497, a flaw in the Brotli compression library that the packages include. The flaw can let an attacker corrupt memory and potentially run code.
PHP says the flaw can be reached through the cURL extension when the extension decompresses HTTP responses automatically. cURL leaves that off by default, but
Oct 26, 2026·The Hacker News
VulnerabilityCritical
Brotli Decoder Flaw Behind Node.js RCE Also Affects Bun, Python and Other Widely Used Software
A memory-corruption flaw in Google's Brotli decoder sits in many programs that unpack Brotli-compressed data, among them Bun, the Python Brotli and brotlicffi packages, and Envoy proxies set up to decompress Brotli.
Tracked as CVE-2026-111497, the flaw allows crafted compressed data to overwrite past the end of a buffer and corrupt a program's memory, potentially
Oct 24, 2026·The Hacker News
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-111497
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-111497
CISA KEV catalogue
https://www.cisa.gov/known-exploited-vulnerabilities-catalog
github.com
https://github.com/andybalholm/brotli/releases/tag/v1.2.7
nodejs.org
https://nodejs.org/en/blog/vulnerability/october-2026-security-releases#nodejs-brotli-decoder-out-of-bounds-write-permits-remote-code-execution-cve-2026-111497---high
www.openwall.com
http://www.openwall.com/lists/oss-security/2026/10/23/25
www.openwall.com
http://www.openwall.com/lists/oss-security/2026/10/24/6
www.openwall.com
http://www.openwall.com/lists/oss-security/2026/10/26/12
www.openwall.com
http://www.openwall.com/lists/oss-security/2026/10/26/13
More from Brotli
6.5
CVE-2020-8927
A buffer overflow exists in the Brotli library versions prior to 1.0.8 where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger…
