Medium severity · published Aug 14, 2025
CVE-2025-55672
Apache Superset: Stored XSS on charts metadata
5.4
CVSS
0.7%
EPSS
No
On KEV
Description
A stored Cross-Site Scripting (XSS) vulnerability exists in Apache Superset's chart visualization. An authenticated user with permissions to edit charts can inject a malicious payload into a column's label. The payload is not properly sanitized and gets executed in the victim's browser when they hover over the chart, potentially leading to session hijacking or the execution of arbitrary commands on behalf of the user. This issue affects Apache Superset: before 5.0.0. Users are recommended to upgrade to version 5.0.0, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.7% · higher than 55% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AS
Apache Superset · Apache Software Foundation
before 5.0.0 · source: vendor
SU
Superset · Apache
before 5.0.0 · source: NVD
Affected product
AS
Apache Superset
Apache Software Foundation
More from Apache Superset
9.8
CVE-2023-27524
Apache Superset: Session validation vulnerability when using provided default SECRET_KEY
9.8
CVE-2024-53947
Apache Superset: Improper SQL authorisation, parse not checking for specific postgres functions
9.8
CVE-2024-39887
Apache Superset: Improper SQL authorisation, parse not checking for specific engine functions
8.8
CVE-2025-27696
Apache Superset: Incorrect authorization leading to resource ownership takeover
6.5
CVE-2026-23985
Apache Superset: Regular Expression Denial of Service (ReDoS) in SQL Parser