High severity · published May 13, 2025
CVE-2025-27696
Apache Superset: Incorrect authorization leading to resource ownership takeover
8.8
CVSS
1.3%
EPSS
No
On KEV
Description
Incorrect Authorization vulnerability in Apache Superset allows ownership takeover of dashboards, charts or datasets by authenticated users with read permissions.
This issue affects Apache Superset: through 4.1.1.
Users are recommended to upgrade to version 4.1.2 or above, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.3% · higher than 70% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AS
Apache Superset · Apache Software Foundation
through 4.1.1 · source: vendor
SU
Superset · Apache
before 4.1.2 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-27696
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-27696
Mailing List
https://lists.apache.org/thread/k2od03bxnxs6vcp80sr03ywcxl194413
Mailing List
http://www.openwall.com/lists/oss-security/2025/05/12/3
More from Apache Superset
9.8
CVE-2023-27524
Apache Superset: Session validation vulnerability when using provided default SECRET_KEY
9.8
CVE-2024-53947
Apache Superset: Improper SQL authorisation, parse not checking for specific postgres functions
9.8
CVE-2024-39887
Apache Superset: Improper SQL authorisation, parse not checking for specific engine functions
6.5
CVE-2026-23985
Apache Superset: Regular Expression Denial of Service (ReDoS) in SQL Parser
6.5
CVE-2026-23969
Apache Superset: Exposure of Sensitive Information via Incomplete ClickHouse Function Filtering
