Medium severity · published Jul 30, 2025
CVE-2025-54572
Ruby SAML DOS vulnerability with large SAML response
6.9
CVSS
0.4%
EPSS
No
On KEV
Description
The Ruby SAML library is for implementing the client side of a SAML authorization. In versions 1.18.0 and below, a denial-of-service vulnerability exists in ruby-saml even with the message_max_bytesize setting configured. The vulnerability occurs because the SAML response is validated for Base64 format prior to checking the message size, leading to potential resource exhaustion. This is fixed in version 1.18.1.
Exploitation
Is it being used?
Exploit prediction (EPSS)0.4% · higher than 37% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
RU
ruby-saml · SAML-Toolkits
< 1.18.1 · source: vendor
Affected product
RU
ruby-saml
SAML-Toolkits
More from ruby-saml
9.8
CVE-2025-25292
Ruby SAML vulnerable to SAML authentication bypass due to namespace handling (parser differential)
9.8
CVE-2025-25291
ruby-saml vulnerable to SAML authentication bypass due to DOCTYPE handling (parser differential)
9.8
CVE-2024-45409
The Ruby SAML library vulnerable to a SAML authentication bypass via Incorrect XPath selector
9.1
CVE-2025-66568
ruby-saml Libxml2 Canonicalization errors can bypass Digest/Signature validation
9.1
CVE-2025-66567
ruby-saml has a SAML authentication bypass due to namespace handling (parser differential)