Critical severity · published Dec 9, 2025
CVE-2025-66568
ruby-saml Libxml2 Canonicalization errors can bypass Digest/Signature validation
9.1
CVSS
0.2%
EPSS
No
On KEV
Description
The ruby-saml library implements the client side of an SAML authorization. Versions up to and including 1.12.4, are vulnerable to authentication bypass through the libxml2 canonicalization process used by Nokogiri for document transformation, which allows an attacker to execute a Signature Wrapping attack. When libxml2’s canonicalization is invoked on an invalid XML input, it may return an empty string rather than a canonicalized node. ruby-saml then proceeds to compute the DigestValue over this empty string, treating it as if canonicalization succeeded. This issue is fixed in version 1.18.0.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.2% · higher than 16% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
RU
ruby-saml · SAML-Toolkits
< 1.18.0 · source: vendor, NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-66568
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-66568
Broken Link
https://github.com/SAML-Toolkits/ruby-saml/commit/acac9e9cc0b9a507882c614f25d41f8b47be349a
Vendor Advisory
https://github.com/SAML-Toolkits/ruby-saml/security/advisories/GHSA-x4h9-gwv3-r4m4
More from ruby-saml
9.8
CVE-2025-25292
Ruby SAML vulnerable to SAML authentication bypass due to namespace handling (parser differential)
9.8
CVE-2025-25291
ruby-saml vulnerable to SAML authentication bypass due to DOCTYPE handling (parser differential)
9.8
CVE-2024-45409
The Ruby SAML library vulnerable to a SAML authentication bypass via Incorrect XPath selector
9.1
CVE-2025-66567
ruby-saml has a SAML authentication bypass due to namespace handling (parser differential)
7.5
CVE-2025-25293
ruby-saml vulnerable to Remote Denial of Service (DoS) with compressed SAML responses
