Medium severity · published May 30, 2025
CVE-2025-48912
Apache Superset: Improper authorization bypass on row level security via SQL Injection
6.5
CVSS
0.8%
EPSS
No
On KEV
Description
An authenticated malicious actor using specially crafted requests could bypass row level security configuration by injecting SQL into 'sqlExpression' fields. This allowed the execution of sub-queries to evade parsing defenses ultimately granting unauthorized access to data.
This issue affects Apache Superset: before 4.1.2.
Users are recommended to upgrade to version 4.1.2, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.8% · higher than 56% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AS
Apache Superset · Apache Software Foundation
before 4.1.2 · source: vendor
SU
Superset · Apache
before 4.1.2 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-48912
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-48912
Mailing List
https://lists.apache.org/thread/ms2t2oq218hb7l628trsogo4fj7h1135
Mailing List
http://www.openwall.com/lists/oss-security/2025/05/30/3
More from Apache Superset
9.8
CVE-2023-27524
Apache Superset: Session validation vulnerability when using provided default SECRET_KEY
9.8
CVE-2024-53947
Apache Superset: Improper SQL authorisation, parse not checking for specific postgres functions
9.8
CVE-2024-39887
Apache Superset: Improper SQL authorisation, parse not checking for specific engine functions
8.8
CVE-2025-27696
Apache Superset: Incorrect authorization leading to resource ownership takeover
6.5
CVE-2026-23985
Apache Superset: Regular Expression Denial of Service (ReDoS) in SQL Parser
