High severity · published Oct 18, 2025
CVE-2025-47410
Apache Geode: CSRF attacks through GET requests to the Management and Monitoring REST API that can execute gfsh commands on the target system
8.8
CVSS
0.4%
EPSS
No
On KEV
Description
Apache Geode is vulnerable to CSRF attacks through GET requests to the Management and Monitoring REST API that could allow an attacker who has tricked a user into giving up their Geode session credentials to submit malicious commands on the target system on behalf of the authenticated user. This issue affects Apache Geode: versions 1.10 through 1.15.1 Users are recommended to upgrade to version 1.15.2, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.4% · higher than 29% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AG
Apache Geode · Apache Software Foundation
1.10.0 before 1.15.2 · source: vendor
GE
Geode · Apache
1.10.0 before 1.15.2 · source: NVD
Affected product
AG
Apache Geode
Apache Software Foundation
More from Apache Geode
7.5
CVE-2026-103371
Apache Geode: Management REST API: Insertion of Sensitive Information into Log File
6.1
CVE-2024-44088
Apache Geode: Reflected XSS
5.4
CVE-2022-34870
Apache Geode stored Cross-Site Scripting (XSS) via data injection vulnerability in Pulse web application