Medium severity · published Oct 14, 2025
CVE-2024-44088
Apache Geode: Reflected XSS
6.1
CVSS
0.7%
EPSS
No
On KEV
Description
Malicious script injection ('Cross-site Scripting') vulnerability in Apache Geode web-api (REST). This vulnerability allows an attacker that tricks a logged-in user into clicking a specially-crafted link to execute code on the returned page, which could lead to theft of the user's session information and even account takeover. This issue affects Apache Geode: all versions prior to 1.15.2 Users are recommended to upgrade to version 1.15.2, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.7% · higher than 53% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AG
Apache Geode · Apache Software Foundation
1.1.0 before 1.15.2 · source: vendor
GE
Geode · Apache
1.1.0 before 1.15.2 · source: NVD
Affected product
AG
Apache Geode
Apache Software Foundation
More from Apache Geode
8.8
CVE-2025-47410
Apache Geode: CSRF attacks through GET requests to the Management and Monitoring REST API that can execute gfsh commands on the target system
7.5
CVE-2026-103371
Apache Geode: Management REST API: Insertion of Sensitive Information into Log File
5.4
CVE-2022-34870
Apache Geode stored Cross-Site Scripting (XSS) via data injection vulnerability in Pulse web application