Medium severity · published Apr 10, 2025
CVE-2025-32027
Yii does not prevent XSS in scenarios where fallback error renderer is used
6.1
CVSS
0.2%
EPSS
No
On KEV
Description
Yii is an open source PHP web framework. Prior to 1.1.31, yiisoft/yii is vulnerable to Reflected XSS in specific scenarios where the fallback error renderer is used. Upgrade yiisoft/yii to version 1.1.31 or higher.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.2% · higher than 16% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
YI
yii · yiisoft
< 1.1.31 · source: vendor, NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-32027
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-32027
Patch
https://github.com/yiisoft/yii/commit/d386d737861c9014269b7ed8c36c65eadb387368
Vendor Advisory
https://github.com/yiisoft/yii/security/advisories/GHSA-7r2v-8wxr-3ch5
More from yii
9.8
CVE-2023-47130
Unsafe deserialization of user data in yiisoft/yii
9.8
CVE-2022-41922
yiisoft/yii before v1.1.27 vulnerable to Remote Code Execution if the application calls `unserialize()` on arbitrary user input
