Critical severity · published Nov 23, 2022
CVE-2022-41922
yiisoft/yii before v1.1.27 vulnerable to Remote Code Execution if the application calls `unserialize()` on arbitrary user input
9.8
CVSS
1.2%
EPSS
No
On KEV
Description
`yiisoft/yii` before version 1.1.27 are vulnerable to Remote Code Execution (RCE) if the application calls `unserialize()` on arbitrary user input. This has been patched in 1.1.27.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.2% · higher than 69% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
YI
yii · yiisoft
< 1.1.27 · source: vendor, NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2022-41922
CVE.org
https://www.cve.org/CVERecord?id=CVE-2022-41922
Patch
https://github.com/yiisoft/yii/commit/ed67b7cc57216557c5c595c6650cdd2d3aa41c52
Third Party Advisory
https://github.com/yiisoft/yii/security/advisories/GHSA-442f-wcwq-fpcf
More from yii
9.8
CVE-2023-47130
Unsafe deserialization of user data in yiisoft/yii
6.1
CVE-2025-32027
Yii does not prevent XSS in scenarios where fallback error renderer is used
