Medium severity · published Dec 9, 2024
CVE-2024-53949
Apache Superset: Lower privilege users are able to create Role when FAB_ADD_SECURITY_API is enabled
6.5
CVSS
0.7%
EPSS
No
On KEV
Description
Improper Authorization vulnerability in Apache Superset when FAB_ADD_SECURITY_API is enabled (disabled by default). Allows for lower privilege users to use this API.  issue affects Apache Superset: from 2.0.0 before 4.1.0. Users are recommended to upgrade to version 4.1.0, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
None
Integrity
High
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.7% · higher than 54% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AS
Apache Superset · Apache Software Foundation
2.0.0 before 4.1.0 · source: vendor
SU
Superset · Apache
2.0.0 before 4.1.0 · source: NVD, CISA
Affected product
AS
Apache Superset
Apache Software Foundation
More from Apache Superset
9.8
CVE-2023-27524
Apache Superset: Session validation vulnerability when using provided default SECRET_KEY
9.8
CVE-2024-53947
Apache Superset: Improper SQL authorisation, parse not checking for specific postgres functions
9.8
CVE-2024-39887
Apache Superset: Improper SQL authorisation, parse not checking for specific engine functions
8.8
CVE-2025-27696
Apache Superset: Incorrect authorization leading to resource ownership takeover
6.5
CVE-2026-23985
Apache Superset: Regular Expression Denial of Service (ReDoS) in SQL Parser