Medium severity · published Apr 9, 2024
CVE-2024-31862
Apache Zeppelin: Denial of service with invalid notebook name
5.3
CVSS
1.4%
EPSS
No
On KEV
Description
Improper Input Validation vulnerability in Apache Zeppelin when creating a new note from Zeppelin's UI.This issue affects Apache Zeppelin: from 0.10.1 before 0.11.0. Users are recommended to upgrade to version 0.11.0, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
None
Availability
Low
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.4% · higher than 72% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AZ
Apache Zeppelin · Apache Software Foundation
0.10.1 before 0.11.0 · source: vendor
ZE
Zeppelin · Apache
0.10.1 before 0.11.0 · source: NVD, CISA
Affected product
AZ
Apache Zeppelin
Apache Software Foundation
More from Apache Zeppelin
9.8
CVE-2024-31866
Apache Zeppelin: Interpreter download command does not escape malicious code injection
9.8
CVE-2024-31864
Apache Zeppelin: Remote code execution by adding malicious JDBC connection string
7.5
CVE-2024-41169
Apache Zeppelin: raft directory listing and file read
6.5
CVE-2026-44615
Path traversal in NotebookRepo note and folder path composition
6.5
CVE-2026-44617
Apache Zeppelin: LDAP filter injection in LdapRealm — incomplete fix of CVE-2024-31867