Critical severity · published Apr 9, 2024
CVE-2024-31866
Apache Zeppelin: Interpreter download command does not escape malicious code injection
9.8
CVSS
1.6%
EPSS
No
On KEV
Description
Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin. The attackers can execute shell scripts or malicious code by overriding configuration like ZEPPELIN_INTP_CLASSPATH_OVERRIDES. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.6% · higher than 75% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AZ
Apache Zeppelin · Apache Software Foundation
0.8.2 before 0.11.1 · source: vendor, CISA
ZE
Zeppelin · Apache
0.8.2 before 0.11.1 · source: NVD
Affected product
AZ
Apache Zeppelin
Apache Software Foundation
More from Apache Zeppelin
9.8
CVE-2024-31864
Apache Zeppelin: Remote code execution by adding malicious JDBC connection string
7.5
CVE-2024-41169
Apache Zeppelin: raft directory listing and file read
6.5
CVE-2026-44615
Path traversal in NotebookRepo note and folder path composition
6.5
CVE-2026-44617
Apache Zeppelin: LDAP filter injection in LdapRealm — incomplete fix of CVE-2024-31867
6.5
CVE-2026-44616
Apache Zeppelin: LDAP injection in ActiveDirectoryGroupRealm filter construction