Medium severity · published Mar 20, 2025
CVE-2024-10723
Stored XSS in phpipam/phpipam
5.4
CVSS
0.3%
EPSS
No
On KEV
Description
A stored cross-site scripting (XSS) vulnerability was discovered in phpipam/phpipam version 1.5.2. This vulnerability allows an attacker to inject malicious scripts into the destination address field of the NAT tool, which can be executed when a user interacts with the field. The impact of this vulnerability includes the potential theft of user cookies, unauthorized access to user accounts, and redirection to malicious websites. The issue has been fixed in version 1.7.0.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.3% · higher than 28% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
PH
phpipam/phpipam · phpipam
before 1.7.0 · source: vendor
PH
Phpipam · Phpipam
before 1.7.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-10723
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-10723
Patch
https://github.com/phpipam/phpipam/commit/c1697bb6c4e4a6403d69c0868e1eb1040f98b731
Exploit
https://huntr.com/bounties/9af99057-e4f6-4d07-b3bb-3213b977801d
More from phpipam/phpipam
7.5
CVE-2024-10718
Cookie without Secure attribute in phpipam/phpipam
6.1
CVE-2024-10727
Cross-Site Scripting (XSS) in phpipam/phpipam
6.1
CVE-2024-10720
Stored Cross-site Scripting (XSS) in phpipam/phpipam
5.9
CVE-2024-0787
Improper Restriction of Excessive Authentication Attempts in phpipam/phpipam
5.4
CVE-2024-10721
Store XSS in phpipam/phpipam
