Medium severity · published Nov 15, 2024
CVE-2024-0787
Improper Restriction of Excessive Authentication Attempts in phpipam/phpipam
5.9
CVSS
0.5%
EPSS
No
On KEV
Description
phpIPAM version 1.5.1 contains a vulnerability where an attacker can bypass the IP block mechanism to brute force passwords for users by using the 'X-Forwarded-For' header. The issue lies in the 'get_user_ip()' function in 'class.Common.php' at lines 1044 and 1045, where the presence of the 'X-Forwarded-For' header is checked and used instead of 'REMOTE_ADDR'. This vulnerability allows attackers to perform brute force attacks on user accounts, including the admin account. The issue is fixed in version 1.7.0.
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Attack vector
Network
Complexity
High
Privileges
None
User interaction
None
Confidentiality
High
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.5% · higher than 40% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
PH
phpipam/phpipam · phpipam
before 1.7.0 · source: vendor
PH
Phpipam · Phpipam
before 1.7.0 · source: NVD, CISA
Affected product
PH
phpipam/phpipam
phpipam
More from phpipam/phpipam
7.5
CVE-2024-10718
Cookie without Secure attribute in phpipam/phpipam
6.1
CVE-2024-10727
Cross-Site Scripting (XSS) in phpipam/phpipam
6.1
CVE-2024-10720
Stored Cross-site Scripting (XSS) in phpipam/phpipam
5.4
CVE-2024-10721
Store XSS in phpipam/phpipam
5.4
CVE-2024-10722
Stored Cross-site Scripting (XSS) in phpipam/phpipam