Medium severity · published Mar 20, 2025
CVE-2024-10722
Stored Cross-site Scripting (XSS) in phpipam/phpipam
5.4
CVSS
0.3%
EPSS
No
On KEV
Description
A stored cross-site scripting (XSS) vulnerability exists in phpipam/phpipam version 1.5.2. The vulnerability allows attackers to inject malicious scripts into the 'Description' field of custom fields in the 'IP RELATED MANAGEMENT' section. This can lead to data theft, account compromise, distribution of malware, website defacement, content manipulation, and phishing attacks. The issue is fixed in version 1.7.0.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.3% · higher than 28% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
PH
phpipam/phpipam · phpipam
before 1.7.0 · source: vendor
PH
Phpipam · Phpipam
before 1.7.0 · source: NVD
Affected product
PH
phpipam/phpipam
phpipam
More from phpipam/phpipam
7.5
CVE-2024-10718
Cookie without Secure attribute in phpipam/phpipam
6.1
CVE-2024-10727
Cross-Site Scripting (XSS) in phpipam/phpipam
6.1
CVE-2024-10720
Stored Cross-site Scripting (XSS) in phpipam/phpipam
5.9
CVE-2024-0787
Improper Restriction of Excessive Authentication Attempts in phpipam/phpipam
5.4
CVE-2024-10721
Store XSS in phpipam/phpipam