Critical severity · published Apr 13, 2022
CVE-2022-27479
Apache Superset before 1.4.2 is vulnerable to SQL injection in chart data requests
9.8
CVSS
2.9%
EPSS
No
On KEV
Description
Apache Superset before 1.4.2 is vulnerable to SQL injection in chart data requests. Users should update to 1.4.2 or higher which addresses this issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)2.9% · higher than 87% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
SU
Superset · Apache
before 1.4.2 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2022-27479
CVE.org
https://www.cve.org/CVERecord?id=CVE-2022-27479
Mailing List
http://www.openwall.com/lists/oss-security/2022/04/13/3
Broken Link
https://lists.apache.org/thread/94th50j5d0y2fw7ysx0g7w3t6jk3z7q6
Broken Link
https://lists.apache.org/thread/ztb9b6jd9rngoxwvq8r4fhpp401o613y
More from Superset
9.8
CVE-2023-27524
Apache Superset: Session validation vulnerability when using provided default SECRET_KEY
9.8
CVE-2024-53947
Apache Superset: Improper SQL authorisation, parse not checking for specific postgres functions
9.8
CVE-2024-39887
Apache Superset: Improper SQL authorisation, parse not checking for specific engine functions
9.8
CVE-2018-8021
Versions of Superset prior to 0.23 used an unsafe load method from the pickle library to deserialize data leading to possible remote code execution
8.8
CVE-2025-27696
Apache Superset: Incorrect authorization leading to resource ownership takeover
