High severity · published Jan 10, 2022
CVE-2021-21408
Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic
8.8
CVSS
2.1%
EPSS
No
On KEV
Description
Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.43 and 4.0.3, template authors could run restricted static php methods. Users should upgrade to version 3.1.43 or 4.0.3 to receive a patch.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)2.1% · higher than 81% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DL
Debian Linux · Debian
9.0; 10.0; 11.0 · source: NVD
FE
Fedora · Fedoraproject
36; 37 · source: NVD
SM
Smarty · Smarty
before 3.1.43; 4.0.0 before 4.0.3 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2021-21408
CVE.org
https://www.cve.org/CVERecord?id=CVE-2021-21408
Patch
https://github.com/smarty-php/smarty/commit/19ae410bf56007a5ef24441cdc6414619cfaf664
Release Notes
https://github.com/smarty-php/smarty/releases/tag/v3.1.43
Release Notes
https://github.com/smarty-php/smarty/releases/tag/v4.0.3
Third Party Advisory
https://github.com/smarty-php/smarty/security/advisories/GHSA-4h9c-v5vg-5m6m
Mailing List
https://lists.debian.org/debian-lts-announce/2022/05/msg00005.html
lists.fedoraproject.org
https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BRAJVDRGCIY5UZ2PQHKDTT7RMKG6WJQQ/
More from Debian Linux
10.0
CVE-2025-32433
Erlang/OTP SSH Vulnerable to Pre-Authentication RCE
10.0
CVE-2025-24201
Apple Multiple Products WebKit Out-of-Bounds Write Vulnerability
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2026-111497
Out-of-Bounds Write in Google Brotli Decoder
