High severity · published Feb 5, 2020
CVE-2020-5208
It's been found that multiple functions in ipmitool before 1.8.19 neglect proper checking of the data received from a remote LAN party, which may lead to buffer overflows and…
8.8
CVSS
3.3%
EPSS
No
On KEV
Description
It's been found that multiple functions in ipmitool before 1.8.19 neglect proper checking of the data received from a remote LAN party, which may lead to buffer overflows and potentially to remote code execution on the ipmitool side. This is especially dangerous if ipmitool is run as a privileged user. This problem is fixed in version 1.8.19.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)3.3% · higher than 88% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DL
Debian Linux · Debian
8.0; 9.0 · source: NVD
FE
Fedora · Fedoraproject
30; 31 · source: NVD
IP
Ipmitool · Ipmitool Project
1.8.18 · source: NVD
LE
Leap · Opensuse
15.1 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2020-5208
CVE.org
https://www.cve.org/CVERecord?id=CVE-2020-5208
Mailing List
http://lists.opensuse.org/opensuse-security-announce/2020-02/msg00031.html
Patch
https://github.com/ipmitool/ipmitool/commit/e824c23316ae50beb7f7488f2055ac65e8b341f2
Patch
https://github.com/ipmitool/ipmitool/security/advisories/GHSA-g659-9qxw-p7cp
Mailing List
https://lists.debian.org/debian-lts-announce/2020/02/msg00006.html
Mailing List
https://lists.debian.org/debian-lts-announce/2021/06/msg00029.html
lists.fedoraproject.org
https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/K2BPW66KDP4H36AGZXLED57A3O2Y6EQW/
More from Debian Linux
10.0
CVE-2025-32433
Erlang/OTP SSH Vulnerable to Pre-Authentication RCE
10.0
CVE-2025-24201
Apple Multiple Products WebKit Out-of-Bounds Write Vulnerability
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2026-111497
Out-of-Bounds Write in Google Brotli Decoder
