High severity · published Mar 16, 2026
CVE-2026-4240
Open5GS CCA smf_s6b_sta_cb denial of service
7.5
CVSS
0.6%
EPSS
No
On KEV
Description
A vulnerability was determined in Open5GS up to 2.7.6. The affected element is the function smf_gx_cca_cb/smf_gy_cca_cb/smf_s6b_aaa_cb/smf_s6b_sta_cb of the component CCA Handler. This manipulation causes denial of service. The attack can be initiated remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 2.7.7 is sufficient to fix this issue. Patch name: 80eb484a6ab32968e755e628b70d1a9c64f012ec. Upgrading the affected component is recommended.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.6% · higher than 46% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
OP
Open5GS · Open5gs
2.7.0; 2.7.1; 2.7.2; 2.7.3; 2.7.4; 2.7.5; +1 more · source: vendor, NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-4240
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-4240
Product
https://github.com/open5gs/open5gs/
Patch
https://github.com/open5gs/open5gs/commit/80eb484a6ab32968e755e628b70d1a9c64f012ec
Issue Tracking
https://github.com/open5gs/open5gs/issues/4343
Exploit
https://github.com/open5gs/open5gs/issues/4343#issue-4021871895
Release Notes
https://github.com/open5gs/open5gs/releases/tag/v2.7.7
Permissions Required
https://vuldb.com/?ctiid.351182
More from Open5GS
9.8
CVE-2026-2522
Open5GS MME esm-build.c memory corruption
9.8
CVE-2026-2521
Open5GS SGW-C sgwc_s5c_handle_create_session_response memory corruption
9.8
CVE-2024-40130
open5gs v2.6.4 is vulnerable to Buffer Overflow
9.8
CVE-2024-40129
Open5GS v2.6.4 is vulnerable to Buffer Overflow
9.8
CVE-2021-28122
A request-validation issue was discovered in Open5GS 2.1.3 through 2.2.x before 2.2.1
