Medium severity · published Jun 12, 2026
CVE-2026-41581
Frappe Vulnerable to Possible SQL Injection via get_blog_list
6.9
CVSS
0.2%
EPSS
No
On KEV
Description
Frappe is a full-stack web application framework. Prior to versions 15.106.0 and 16.16.0, there is a possible SQL Injection via get_blog_list. This issue has been patched in versions 15.106.0 and 16.16.0.
Exploitation
Is it being used?
Exploit prediction (EPSS)0.2% · higher than 14% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
FR
frappe · frappe
< 15.106.0; < 16.16.0 · source: vendor
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-41581
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-41581
github.com
https://github.com/frappe/frappe/security/advisories/GHSA-h9hf-57r4-cm65
More from frappe
9.9
CVE-2026-119145
Frappe before 15.121.0 and 16.x before 16.34.0 Path Traversal RCE via File Upload
9.8
CVE-2026-35614
Frappe has a SQL injection in bulk_update
9.8
CVE-2026-31877
Frappe SQL Injection due to improper field sanitization
9.8
CVE-2025-66205
Frappe has the possibility of SQL Injection due to improper validations
9.8
CVE-2019-14965
An issue was discovered in Frappe Framework 10 through 12 before 12.0.4
