Critical severity · published Dec 22, 2025
CVE-2025-68615
Net-SNMP snmptrapd crash
9.8
CVSS
42.4%
EPSS
No
On KEV
Description
net-snmp is a SNMP application library, tools and daemon. Prior to versions 5.9.5 and 5.10.pre2, a specially crafted packet to an net-snmp snmptrapd daemon can cause a buffer overflow and the daemon to crash. This issue has been patched in versions 5.9.5 and 5.10.pre2.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)42.4% · higher than 99% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
NE
net-snmp · net-snmp
< 5.9.5; >= 5.10.pre1, < 5.10.pre2 · source: vendor, NVD
DL
Debian Linux · Debian
11.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-68615
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-68615
Vendor Advisory
https://github.com/net-snmp/net-snmp/security/advisories/GHSA-4389-rwqf-q9gq
Mailing List
http://www.openwall.com/lists/oss-security/2026/01/09/2
Mailing List
https://lists.debian.org/debian-lts-announce/2026/01/msg00000.html
Exploit
https://www.vicarius.io/vsociety/posts/cve-2025-68615-detection-script-buffer-overflow-vulnerability-affecting-net-snmp
Mitigation
https://www.vicarius.io/vsociety/posts/cve-2025-68615-mitigation-script-buffer-overflow-vulnerability-affecting-net-snmp
More from net-snmp
9.8
CVE-2018-1000116
NET-SNMP version 5.7.2 contains a heap corruption vulnerability in the UDP protocol handler that can result in command execution
8.8
CVE-2022-24810
net-snmp provides various tools relating to the Simple Network Management Protocol
8.8
CVE-2022-24805
net-snmp provides various tools relating to the Simple Network Management Protocol
7.8
CVE-2020-15862
Net-SNMP through 5.8 has Improper Privilege Management because SNMP WRITE access to the EXTEND MIB provides the ability to run arbitrary commands as root
7.8
CVE-2020-15861
Net-SNMP through 5.7.3 allows Escalation of Privileges because of UNIX symbolic link (symlink) following
