Medium severity · published Jan 14, 2026
CVE-2025-66169
Apache Camel Neo4j: Cypher injection vulnerability in Camel-Neo4j component
5.3
CVSS
0.6%
EPSS
No
On KEV
Description
Cypher Injection vulnerability in Apache Camel camel-neo4j component. This issue affects Apache Camel: from 4.10.0 before 4.10.8, from 4.14.0 before 4.14.3, from 4.15.0 before 4.17.0 Users are recommended to upgrade to version 4.10.8 for 4.10.x LTS and 4.14.3 for 4.14.x LTS and 4.17.0.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
Low
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.6% · higher than 51% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AC
Apache Camel Neo4j · Apache Software Foundation
4.10.0 before 4.10.8; 4.14.0 before 4.14.3; 4.15.0 before 4.17.0 · source: vendor
CA
Camel · Apache
4.10.0 before 4.10.8; 4.14.0 before 4.14.3; 4.15.0 before 4.17.0 · source: NVD