Low severity · published Sep 3, 2025
CVE-2025-58064
CKEditor is susceptible to Cross-Site Scripting (XSS) through its clipboard package
2.3
CVSS
0.4%
EPSS
No
On KEV
Description
CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. ckeditor5 and ckeditor5-clipboard versions 46.0.0 through 46.0.2 and 44.2.0 through 45.2.1 contain a Cross-Site Scripting (XSS) vulnerability. Ability to exploit could be triggered by a specific user action (leading to unauthorized JavaScript code execution) if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability affects installations where the editor configuration meets one of the following criteria: the HTML embed plugin is enabled, or there is a custom plugin introducing an editable element where view RawElement is enabled. This issue is fixed in versions 45.2.2 and 46.0.3 of both ckeditor5 and ckeditor5-clipboard.
Exploitation
Is it being used?
Exploit prediction (EPSS)0.4% · higher than 36% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
CK
ckeditor5 · ckeditor
>= 46.0.0, < 46.0.3; >= 44.2.0, < 45.2.2 · source: vendor
Affected product
CK
ckeditor5
ckeditor
More from ckeditor5
8.1
CVE-2026-116688
CKEditor: Cross-site scripting (XSS) in the engine package
6.5
CVE-2021-21254
CKEditor 5 is an open source rich text editor framework with a modular architecture
6.1
CVE-2026-28343
CKEditor: Cross-site scripting (XSS) in the HTML Support package
6.1
CVE-2024-45613
CKEditor 5 has Cross-site Scripting vulnerability in the clipboard package
5.4
CVE-2025-61261
A reflected cross-site scripting (XSS) vulnerability in CKeditor v46.1.0 & Angular v18.0.0 allows attackers to execute arbitrary code in the context of a user's browser via…