High severity · published May 26, 2025
CVE-2025-5174
erdogant pypickle pypickle.py load deserialization
7.8
CVSS
0.3%
EPSS
No
On KEV
Description
A vulnerability was found in erdogant pypickle up to 1.1.5 and classified as problematic. Affected by this issue is the function load of the file pypickle/pypickle.py. The manipulation leads to deserialization. Local access is required to approach this attack. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.0 is able to address this issue. The patch is identified as 14b4cae704a0bb4eb6723e238f25382d847a1917. It is recommended to upgrade the affected component.
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Attack vector
Local
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.3% · higher than 27% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
PY
pypickle · erdogant
1.1.0; 1.1.1; 1.1.2; 1.1.3; 1.1.4; 1.1.5 · source: vendor, NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-5174
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-5174
Patch
https://github.com/erdogant/pypickle/commit/14b4cae704a0bb4eb6723e238f25382d847a1917
Exploit
https://github.com/erdogant/pypickle/issues/2
Exploit
https://github.com/erdogant/pypickle/issues/2#issuecomment-2889146579
Release Notes
https://github.com/erdogant/pypickle/releases/tag/2.0.0
Permissions Required
https://vuldb.com/?ctiid.310262
Third Party Advisory
https://vuldb.com/?id.310262
More from pypickle
5.5
CVE-2025-5175
erdogant pypickle pypickle.py save improper authorization
