High severity · published Jul 8, 2025
CVE-2025-48385
Git alllows arbitrary file writes via bundle-uri parameter injection
8.6
CVSS
1.1%
EPSS
No
On KEV
Description
Git is a fast, scalable, distributed revision control system with an unusually rich command set that provides both high-level operations and full access to internals. When cloning a repository Git knows to optionally fetch a bundle advertised by the remote server, which allows the server-side to offload parts of the clone to a CDN. The Git client does not perform sufficient validation of the advertised bundles, which allows the remote side to perform protocol injection. This protocol injection can cause the client to write the fetched bundle to a location controlled by the adversary. The fetched content is fully controlled by the server, which can in the worst case lead to arbitrary code execution. The use of bundle URIs is not enabled by default and can be controlled by the bundle.heuristic config option. Some cases of the vulnerability require that the adversary is in control of where a repository will be cloned to. This either requires social engineering or a recursive clone with submodules. These cases can thus be avoided by disabling recursive clones. This vulnerability is fixed in v2.43.7, v2.44.4, v2.45.4, v2.46.4, v2.47.3, v2.48.2, v2.49.1, and v2.50.1.
Exploitation
Is it being used?
Exploit prediction (EPSS)1.1% · higher than 64% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
GI
git · git
< 2.43.7; >= 2.44.0-rc0, < 2.44.4; >= 2.45.0-rc0, < 2.45.4; >= 2.46.0-rc0, < 2.46.4; >= 2.47.0-rc0, < 2.47.3; >= 2.48.0-rc0, < 2.48.2; +2 more · source: vendor
Affected product
GI
git
git
More from git
8.0
CVE-2025-48384
Git allows arbitrary code execution through broken config quoting
9.8
CVE-2022-25648
The package git before 1.11.0 are vulnerable to Command Injection via git argument injection
9.0
CVE-2024-32002
Git is a revision control system
8.8
CVE-2024-52005
The sideband payload is passed unfiltered to the terminal in git
8.8
CVE-2022-39260
Git vulnerable to Remote Code Execution via Heap overflow in `git shell`