High severity · published May 5, 2025
CVE-2025-46731
Craft CMS Contains a Potential Remote Code Execution Vulnerability via Twig SSTI
7.2
CVSS
1.5%
EPSS
No
On KEV
Description
Craft is a content management system. Versions of Craft CMS on the 4.x branch prior to 4.14.13 and on the 5.x branch prior to 5.6.16 contains a potential remote code execution vulnerability via Twig SSTI. One must have administrator access and `ALLOW_ADMIN_CHANGES` must be enabled for this to work. Users should update to the patched versions 4.14.13 or 5.6.15 to mitigate the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
High
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.5% · higher than 74% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
CM
cms · craftcms
>= 4.0.0-RC1, < 4.14.13; >= 5.0.0-RC1, < 5.6.15 · source: vendor
CC
Craft Cms · Craftcms
4.1.0 before 4.14.13; 5.1.0 before 5.6.15; 4.0.0; 4.0.0; 4.0.0; 5.0.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-46731
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-46731
Patch
http://github.com/craftcms/cms/pull/17026
Product
https://craftcms.com/knowledge-base/securing-craft#set-allowAdminChanges-to-false-in-production
Third Party Advisory
https://github.com/craftcms/cms/security/advisories/GHSA-7c58-g782-9j38
Not Applicable
https://github.com/craftcms/cms/security/advisories/GHSA-f3cw-hg6r-chfv
More from cms
10.0
CVE-2025-32432
Craft CMS Allows Remote Code Execution
9.8
CVE-2024-56145
RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms
8.1
CVE-2025-23209
Potential RCE with a compromised security key in craft/cms
9.8
CVE-2026-112776
Craft CMS 5.0.0 before 5.11.0 GraphQL Site-Scope Bypass via Mutations
9.8
CVE-2026-84795
Craft CMS before 5.10.11 Authentication Bypass via Admin Flag Inheritance
