Medium severity · published Jul 2, 2025
CVE-2025-46647
Apache APISIX: improper validation of issuer from introspection discovery url in plugin openid-connect
5.3
CVSS
0.5%
EPSS
No
On KEV
Description
A vulnerability of plugin openid-connect in Apache APISIX. This vulnerability will only have an impact if all of the following conditions are met: 1. Use the openid-connect plugin with introspection mode 2. The auth service connected to openid-connect provides services to multiple issuers 3. Multiple issuers share the same private key and relies only on the issuer being different If affected by this vulnerability, it would allow an attacker with a valid account on one of the issuers to log into the other issuer. This issue affects Apache APISIX: until 3.12.0. Users are recommended to upgrade to version 3.12.0 or higher.
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
Attack vector
Network
Complexity
High
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.5% · higher than 41% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AA
Apache APISIX · Apache Software Foundation
before 3.12.0 · source: vendor
AP
Apisix · Apache
before 3.12.0 · source: NVD
Affected product
AA
Apache APISIX
Apache Software Foundation
More from Apache APISIX
9.8
CVE-2022-24112
apisix/batch-requests plugin allows overwriting the X-REAL-IP header
9.3
CVE-2026-49871
Apache APISIX: cas-auth login CSRF / session injection issue
9.1
CVE-2026-49230
Apache APISIX: Authentication bypass in jwe-decrypt
9.1
CVE-2026-44087
Apache APISIX: Openid-connect plugin Identity Header Spoofing
9.1
CVE-2026-39999
Apache APISIX: JWT Algorithm Confusion allows authentication bypass