Medium severity · published Apr 9, 2025
CVE-2025-30677
Apache Pulsar IO Kafka Connector, Apache Pulsar IO Kafka Connect Adaptor: Sensitive information logged in Pulsar's Apache Kafka Connectors
6.5
CVSS
0.7%
EPSS
No
On KEV
Description
Apache Pulsar contains multiple connectors for integrating with Apache Kafka. The Pulsar IO Apache Kafka Source Connector, Sink Connector, and Kafka Connect Adaptor Sink Connector log sensitive configuration properties in plain text in application logs. This vulnerability can lead to unintended exposure of credentials in log files, potentially allowing attackers with access to these logs to obtain Apache Kafka credentials. The vulnerability's impact is limited by the fact that an attacker would need access to the application logs to exploit this issue. This issue affects Apache Pulsar IO's Apache Kafka connectors in all versions before 3.0.11, 3.3.6, and 4.0.4. 3.0.x version users should upgrade to at least 3.0.11. 3.3.x version users should upgrade to at least 3.3.6. 4.0.x version users should upgrade to at least 4.0.4. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.7% · higher than 54% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AP
Apache Pulsar IO Kafka Connect Adaptor · Apache Software Foundation
2.3.0 before 3.0.11; 3.1.0 before 3.3.6; 4.0.0 before 4.0.4 · source: vendor
AP
Apache Pulsar IO Kafka Connector · Apache Software Foundation
2.3.0 before 3.0.11; 3.1.0 before 3.3.6; 4.0.0 before 4.0.4 · source: vendor
PU
Pulsar · Apache
2.3.0 before 3.0.11; 3.3.0 before 3.3.6; 4.0.0 before 4.0.4 · source: NVD