Medium severity · published Jul 31, 2025
CVE-2025-24854
Apache JSPWiki: Cross-Site Scripting (XSS) in JSPWiki Image plugin
6.1
CVSS
0.5%
EPSS
No
On KEV
Description
A carefully crafted request using the Image plugin could trigger an XSS
vulnerability on Apache JSPWiki, which could allow the attacker to
execute javascript in the victim's browser and get some sensitive
information about the victim.
Apache JSPWiki users should upgrade to 2.12.3 or later.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.5% · higher than 41% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AJ
Apache JSPWiki · Apache Software Foundation
through 2.12.2 · source: vendor
JS
Jspwiki · Apache
before 2.12.3 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-24854
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-24854
Vendor Advisory
https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2025-24854
www.openwall.com
http://www.openwall.com/lists/oss-security/2025/07/30/3
More from Apache JSPWiki
9.8
CVE-2026-28812
Apache JSPWiki: UserManager does not sanity-check user database at startup
8.8
CVE-2026-28813
Apache JSPWiki: JSPWiki vulnerable to JSON hijacking
8.8
CVE-2022-34158
User Group Privilege Escalation
7.5
CVE-2026-28814
Apache JSPWiki: Pre-Authentication Arbitrary Wiki Markup Rendering
7.5
CVE-2026-28811
Apache JSPWiki: Error Handling - Reveals Error Details
