Medium severity · published Dec 29, 2025
CVE-2025-14280
PixelYourSite <= 11.1.5 - Sensitive Information Exposure via Log File
5.3
CVSS
0.4%
EPSS
No
On KEV
Description
The PixelYourSite plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 11.1.5 through publicly exposed log files. This makes it possible for unauthenticated attackers to view potentially sensitive information contained in the exposed log files, when the "Meta API logs" setting is enabled (disabled by default). The vulnerability was partially patched in version 11.1.5 and fully patched in version 11.1.5.1.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
Low
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.4% · higher than 37% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
Affected product
PY
PixelYourSite – Your smart PIXEL (TAG) & API Manager
pixelyoursite
More from PixelYourSite – Your smart PIXEL (TAG) & API Manager
7.5
CVE-2024-7870
PixelYourSite – Your smart PIXEL (TAG) & API Manager <= 9.7.1 and PixelYourSite PRO <= 10.4.2 - Unauthenticated Information Exposure and Log Deletion
7.2
CVE-2026-1841
PixelYourSite <= 11.2.0 - Unauthenticated Stored Cross-Site Scripting
5.3
CVE-2026-18059
PixelYourSite <= 11.2.1 - Unauthenticated Sensitive Information Exposure via Order-Received Endpoint Missing Key Validation
4.8
CVE-2023-2584
PixelYourSite <= 9.3.6 and PixelYourSite Pro <= 9.6.1 - Authenticated (Administrator+) Stored Cross-Site Scripting
4.3
CVE-2025-10588
PixelYourSite <= 11.1.2 – Cross-Site Request Forgery to GDPR Options Modification