High severity · published Feb 12, 2025
CVE-2025-1215
vim main.c memory corruption
7.8
CVSS
0.5%
EPSS
No
On KEV
Description
A vulnerability classified as problematic was found in vim up to 9.1.1096. This vulnerability affects unknown code of the file src/main.c. The manipulation of the argument --log leads to memory corruption. It is possible to launch the attack on the local host. Upgrading to version 9.1.1097 is able to address this issue. The patch is identified as c5654b84480822817bb7b69ebc97c174c91185e9. It is recommended to upgrade the affected component.
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Attack vector
Local
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.5% · higher than 46% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
VI
vim ·
9.1.1096 · source: vendor, NVD
BO
Bootstrap OS · Netapp
All versions, or not specified · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-1215
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-1215
Patch
https://github.com/vim/vim/commit/c5654b84480822817bb7b69ebc97c174c91185e9
Exploit
https://github.com/vim/vim/issues/16606
Release Notes
https://github.com/vim/vim/releases/tag/v9.1.1097
Permissions Required
https://vuldb.com/?ctiid.295174
Third Party Advisory
https://vuldb.com/?id.295174
Third Party Advisory
https://vuldb.com/?submit.497546
More from vim
7.5
CVE-2022-3705
vim autocmd quickfix.c qf_update_buffer use after free
5.5
CVE-2025-9390
vim xxd xxd.c main buffer overflow
5.5
CVE-2025-9389
vim memmove-vec-unaligned-erms.S __memmove_avx_unaligned_erms memory corruption
