Low severity · published Feb 27, 2025
CVE-2025-0914
Velociraptor Shell Plugin Prevent_execve Bypass
3.8
CVSS
0.2%
EPSS
No
On KEV
Description
An improper access control issue in the VQL shell feature in Velociraptor Versions < 0.73.4 allowed authenticated users to execute the execve() plugin in deployments where this was explicitly forbidden by configuring the prevent_execve flag in the configuration file. This setting is not usually recommended and is uncommonly used, so this issue will only affect users who do set it. This issue is fixed in release 0.73.4.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
High
User interaction
None
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.2% · higher than 14% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
VE
Velociraptor · Rapid7
before 0.73.4 · source: vendor
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-0914
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-0914
docs.velociraptor.app
https://docs.velociraptor.app/announcements/advisories/cve-2025-0914/
More from Velociraptor
9.9
CVE-2026-19072
Velociraptor Investigator reaches SuperUser via hunt EffectivePrincipal
9.9
CVE-2026-19583
Velociraptor Required Permissions bypass by using client monitoring queries
9.6
CVE-2026-18972
Velociraptor authenticated identity-spoofing vulnerability
9.1
CVE-2026-6290
Velociraptor Query() Plugin Misapplies Permissions To Orgs
8.9
CVE-2026-19200
Velociraptor Analyst overwrites live built-in artifacts through verify()
