High severity · published Aug 8, 2024
CVE-2024-7272
FFmpeg swresample.c fill_audiodata heap-based overflow
8.8
CVSS
1.2%
EPSS
No
On KEV
Description
A vulnerability, which was classified as critical, was found in FFmpeg up to 5.1.5. This affects the function fill_audiodata of the file /libswresample/swresample.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. This issue was fixed in version 6.0 by 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 but a backport for 5.1 was forgotten. The exploit has been disclosed to the public and may be used. Upgrading to version 5.1.6 and 6.0 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 is able to address this issue. It is recommended to upgrade the affected component.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.2% · higher than 68% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
FF
FFmpeg ·
5.1.0; 5.1.1; 5.1.2; 5.1.3; 5.1.4; 5.1.5 · source: vendor, NVD, CISA
Affected product
FF
FFmpeg
More from FFmpeg
8.8
CVE-2025-1594
FFmpeg AAC Encoder aacenc_tns.c ff_aac_search_for_tns stack-based overflow
8.8
CVE-2024-7055
FFmpeg pnmdec.c pnm_decode_frame heap-based overflow
8.1
CVE-2022-3964
ffmpeg QuickTime RPZA Video Encoder rpzaenc.c out-of-bounds
8.1
CVE-2022-3965
ffmpeg QuickTime Graphics Video Encoder smcenc.c smc_encode_stream out-of-bounds
7.5
CVE-2022-3109
An issue was discovered in the FFmpeg package, where vp3_decode_frame in libavcodec/vp3.c lacks check of the return value of av_malloc() and will cause a null pointer dereference,…