High severity · published Nov 21, 2024
CVE-2024-52797
Searching Opencast may cause a denial of service
7.5
CVSS
0.9%
EPSS
No
On KEV
Description
Opencast is free and open source software for automated video capture and distribution. First noticed in Opencast 13 and 14, Opencast's Elasticsearch integration may generate syntactically invalid Elasticsearch queries in relation to previously acceptable search queries. From Opencast version 11.4 and newer, Elasticsearch queries are retried a configurable number of times in the case of error to handle temporary losses of connection to Elasticsearch. These invalid queries would fail, causing the retry mechanism to begin requerying with the same syntactically invalid query immediately, in an infinite loop. This causes a massive increase in log size which can in some cases cause a denial of service due to disk exhaustion.
Opencast 13.10 and Opencast 14.3 contain patches which address the base issue, with Opencast 16.7 containing changes which harmonize the search behaviour between the admin UI and external API. Users are strongly recommended to upgrade as soon as possible if running versions prior to 13.10 or 14.3. While the relevant endpoints require (by default) `ROLE_ADMIN` or `ROLE_API_SERIES_VIEW`, the problem queries are otherwise innocuous. This issue could be easily triggered by normal administrative work on an affected Opencast system. Those who run a version newer than 13.10 and 14.3 and see different results when searching in their admin UI vs your external API or LMS, may resolve the issue by upgrading to 16.7. No known workarounds for the vulnerability are available.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.9% · higher than 60% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
OP
opencast · opencast
>= 11.4, < 13.10; >= 14.0, < 14.3; >= 15.0, < 16.7 · source: vendor, NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-52797
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-52797
github.com
https://github.com/opencast/opencast/commit/3d5ebd163674eb18e070f52b64a18f92188f98c3
Issue Tracking
https://github.com/opencast/opencast/pull/5033
Issue Tracking
https://github.com/opencast/opencast/pull/5150
Vendor Advisory
https://github.com/opencast/opencast/security/advisories/GHSA-jh6x-7xfg-9cq2
More from opencast
8.8
CVE-2026-77614
Opencast: Session fixation in login enables account takeover via crafted link
8.8
CVE-2017-1000217
Opencast 2.3.2 and older versions are vulnerable to script injections through media and metadata in the player and media module resulting in arbitrary code execution, fixed in…
8.7
CVE-2026-77615
Paella Player: Stored XSS via caption cue text
6.5
CVE-2025-54380
Opencast still publishes global system account credentials
5.4
CVE-2025-61788
Opencast Paella Player 7 vulnerable to Cross-Site-Scripting
