Medium severity · published Sep 17, 2024
CVE-2024-45605
Improper authorization on deletion of user issue alert notifications in sentry
4.3
CVSS
0.4%
EPSS
No
On KEV
Description
Sentry is a developer-first error tracking and performance monitoring platform. An authenticated user delete the user issue alert notifications for arbitrary users given a know alert ID. A patch was issued to ensure authorization checks are properly scoped on requests to delete user alert notifications. Sentry SaaS users do not need to take any action. Self-Hosted Sentry users should upgrade to version 24.9.0 or higher. There are no known workarounds for this vulnerability.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
None
Integrity
Low
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.4% · higher than 33% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
SE
sentry · getsentry
>=23.9.0, < 24.9.0 · source: vendor, NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-45605
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-45605
Product
https://github.com/getsentry/self-hosted
Issue Tracking
https://github.com/getsentry/sentry/pull/77093
Vendor Advisory
https://github.com/getsentry/sentry/security/advisories/GHSA-54m3-95j9-v89j
More from sentry
9.8
CVE-2026-42354
Sentry: Improper authentication on SAML SSO process allows user identity linking
9.1
CVE-2026-27197
Sentry: Improper Authentication on SAML SSO process allows user identity linking
9.1
CVE-2025-22146
Improper authentication on SAML SSO process allows user impersonation in sentry
8.1
CVE-2023-39349
Sentry vulnerable to privilege escalation via ApiTokensEndpoint
7.7
CVE-2026-83803
Sentry: Unsafe pickle deserialization in Relocation Feature
