Medium severity · published Aug 3, 2025
CVE-2024-41177
Apache Zeppelin: XSS in the Helium module
6.1
CVSS
0.7%
EPSS
No
On KEV
Description
Incomplete Blacklist to Cross-Site Scripting vulnerability in Apache Zeppelin. This issue affects Apache Zeppelin: before 0.12.0. Users are recommended to upgrade to version 0.12.0, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.7% · higher than 52% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AZ
Apache Zeppelin · Apache Software Foundation
before 0.12.0 · source: vendor
ZE
Zeppelin · Apache
before 0.12.0 · source: NVD
Affected product
AZ
Apache Zeppelin
Apache Software Foundation
More from Apache Zeppelin
7.5
CVE-2024-41169
Apache Zeppelin: raft directory listing and file read
6.5
CVE-2026-44615
Path traversal in NotebookRepo note and folder path composition
6.5
CVE-2026-44617
Apache Zeppelin: LDAP filter injection in LdapRealm — incomplete fix of CVE-2024-31867
6.5
CVE-2026-44616
Apache Zeppelin: LDAP injection in ActiveDirectoryGroupRealm filter construction
6.1
CVE-2026-44613
Apache Zeppelin: Cross-site request forgery in REST and WebSocket request handling