High severity · published Dec 27, 2023
CVE-2023-50255
Zip Path Traversal in Deepin-Compressor
7.8
CVSS
1.1%
EPSS
No
On KEV
Description
Deepin-Compressor is the default archive manager of Deepin Linux OS. Prior to 5.12.21, there's a path traversal vulnerability in deepin-compressor that can be exploited to achieve Remote Command Execution on the target system upon opening crafted archives. Users are advised to update to version 5.12.21 which addresses the issue. There are no known workarounds for this vulnerability.
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Attack vector
Local
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.1% · higher than 64% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DE
developer-center · linuxdeepin
< 5.12.21 · source: vendor
DE
Deepin-compressor · Deepin
before 5.12.21 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2023-50255
CVE.org
https://www.cve.org/CVERecord?id=CVE-2023-50255
Patch
https://github.com/linuxdeepin/deepin-compressor/commit/82f668c78c133873f5094cfab6e4eabc0b70e4b6
Exploit
https://github.com/linuxdeepin/developer-center/security/advisories/GHSA-rw5r-8p9h-3gp2
More from developer-center
7.8
CVE-2023-50254
Deepin Reader RCE vulnerability due to a design flaw
