Medium severity · published Aug 9, 2023
CVE-2023-39531
Sentry vulnerable to incorrect credential validation on OAuth token requests
6.8
CVSS
0.4%
EPSS
No
On KEV
Description
Sentry is an error tracking and performance monitoring platform. Starting in version 10.0.0 and prior to version 23.7.2, an attacker with sufficient client-side exploits could retrieve a valid access token for another user during the OAuth token exchange due to incorrect credential validation. The client ID must be known and the API application must have already been authorized on the targeted user account. Sentry SaaS customers do not need to take any action. Self-hosted installations should upgrade to version 23.7.2 or higher. There are no direct workarounds, but users should review applications authorized on their account and remove any that are no longer needed.
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
Attack vector
Network
Complexity
High
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
High
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.4% · higher than 29% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
SE
sentry · getsentry
>= 10.0.0, < 23.7.2 · source: vendor, NVD
Affected product
SE
sentry
getsentry
More from sentry
9.8
CVE-2026-42354
Sentry: Improper authentication on SAML SSO process allows user identity linking
9.1
CVE-2026-27197
Sentry: Improper Authentication on SAML SSO process allows user identity linking
9.1
CVE-2025-22146
Improper authentication on SAML SSO process allows user impersonation in sentry
8.1
CVE-2023-39349
Sentry vulnerable to privilege escalation via ApiTokensEndpoint
7.7
CVE-2026-83803
Sentry: Unsafe pickle deserialization in Relocation Feature