Critical severity · published Aug 4, 2023
CVE-2023-38692
CloudExplorer Lite is an open source, lightweight cloud management platform
9.8
CVSS
3.4%
EPSS
No
On KEV
Description
CloudExplorer Lite is an open source, lightweight cloud management platform. Versions prior to 1.3.1 contain a command injection vulnerability in the installation function in module management. The vulnerability has been fixed in v1.3.1. There are no known workarounds aside from upgrading.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)3.4% · higher than 89% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
CL
Cloudexplorer Lite · Fit2cloud
before 1.3.1 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2023-38692
CVE.org
https://www.cve.org/CVERecord?id=CVE-2023-38692
Product
https://github.com/CloudExplorer-Dev/CloudExplorer-Lite/blob/v1.3.0/framework/management-center/backend/src/main/java/com/fit2cloud/controller/ModuleManageController.java
Release Notes
https://github.com/CloudExplorer-Dev/CloudExplorer-Lite/releases/tag/v1.3.1
Exploit
https://github.com/CloudExplorer-Dev/CloudExplorer-Lite/security/advisories/GHSA-7wrc-f42m-9v5w
More from Cloudexplorer Lite
9.8
CVE-2023-44397
CloudExplorer Lite permission bypass vulnerability
9.8
CVE-2023-34240
Cloudexplorer-lite is an open source cloud software stack
8.8
CVE-2023-3423
Weak Password Requirements in GitHub repository cloudexplorer-dev/cloudexplorer-lite prior to v 1.2.0
8.1
CVE-2023-2845
Improper Access Control in GitHub repository cloudexplorer-dev/cloudexplorer-lite prior to v1.1.0
7.8
CVE-2023-50612
Insecure Permissions vulnerability in fit2cloud Cloud Explorer Lite version 1.4.1, allow local attackers to escalate privileges and obtain sensitive information via the cloud…
