Medium severity · published Jul 25, 2023
CVE-2023-36826
Sentry vulnerable to improper authorization on debug and artifact file downloads
6.5
CVSS
0.6%
EPSS
No
On KEV
Description
Sentry is an error tracking and performance monitoring platform. Starting in version 8.21.0 and prior to version 23.5.2, an authenticated user can download a debug or artifact bundle from arbitrary organizations and projects with a known bundle ID. The user does not need to be a member of the organization or have permissions on the project. A patch was issued in version 23.5.2 to ensure authorization checks are properly scoped on requests to retrieve debug or artifact bundles. Authenticated users who do not have the necessary permissions on the particular project are no longer able to download them. Sentry SaaS users do not need to take any action. Self-Hosted Sentry users should upgrade to version 23.5.2 or higher.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.6% · higher than 50% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
SE
sentry · getsentry
>= 8.21.0, < 23.5.2 · source: vendor, NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2023-36826
CVE.org
https://www.cve.org/CVERecord?id=CVE-2023-36826
Patch
https://github.com/getsentry/sentry/commit/e932b15435bf36239431eaa3790a6bcfa47046a9
Patch
https://github.com/getsentry/sentry/pull/49680
Vendor Advisory
https://github.com/getsentry/sentry/security/advisories/GHSA-m4hc-m2v6-hfw8
More from sentry
9.8
CVE-2026-42354
Sentry: Improper authentication on SAML SSO process allows user identity linking
9.1
CVE-2026-27197
Sentry: Improper Authentication on SAML SSO process allows user identity linking
9.1
CVE-2025-22146
Improper authentication on SAML SSO process allows user impersonation in sentry
8.1
CVE-2023-39349
Sentry vulnerable to privilege escalation via ApiTokensEndpoint
7.7
CVE-2026-83803
Sentry: Unsafe pickle deserialization in Relocation Feature
