Critical severity · published Nov 20, 2023
CVE-2022-46337
Apache Derby: LDAP injection vulnerability in authenticator
9.8
CVSS
1.4%
EPSS
No
On KEV
Description
A cleverly devised username might bypass LDAP authentication checks. In
LDAP-authenticated Derby installations, this could let an attacker fill
up the disk by creating junk Derby databases. In LDAP-authenticated
Derby installations, this could also allow the attacker to execute
malware which was visible to and executable by the account which booted
the Derby server. In LDAP-protected databases which weren't also
protected by SQL GRANT/REVOKE authorization, this vulnerability could
also let an attacker view and corrupt sensitive data and run sensitive
database functions and procedures.
Mitigation:
Users should upgrade to Java 21 and Derby 10.17.1.0.
Alternatively, users who wish to remain on older Java versions should
build their own Derby distribution from one of the release families to
which the fix was backported: 10.16, 10.15, and 10.14. Those are the
releases which correspond, respectively, with Java LTS versions 17, 11,
and 8.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.4% · higher than 73% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AD
Apache Derby · Apache Software Foundation
10.1.1.0 through 10.1.3.1; 10.2.1.6 through 10.2.2.0; 10.3.1.4 through 10.3.3.0; 10.4.1.3 through 10.4.2.0; 10.5.1.1 through 10.5.3.0; 10.6.1.0 through 10.6.2.1; +10 more · source: vendor
DE
Derby · Apache
10.1.1.0 before 10.14.3.0; 10.15.1.3 before 10.15.2.1; 10.16.1.1 · source: NVD
