High severity · published Dec 12, 2022
CVE-2022-41881
Netty project is an event-driven asynchronous network application framework
7.5
CVSS
1.6%
EPSS
No
On KEV
Description
Netty project is an event-driven asynchronous network application framework. In versions prior to 4.1.86.Final, a StackOverflowError can be raised when parsing a malformed crafted message due to an infinite recursion. This issue is patched in version 4.1.86.Final. There is no workaround, except using a custom HaProxyMessageDecoder.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.6% · higher than 75% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DL
Debian Linux · Debian
10.0; 11.0 · source: NVD
NE
Netty · Netty
before 4.1.86 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2022-41881
CVE.org
https://www.cve.org/CVERecord?id=CVE-2022-41881
Exploit
https://github.com/netty/netty/security/advisories/GHSA-fx2c-96vj-985v
Mailing List
https://lists.debian.org/debian-lts-announce/2023/01/msg00008.html
Third Party Advisory
https://security.netapp.com/advisory/ntap-20230113-0004/
Third Party Advisory
https://www.debian.org/security/2023/dsa-5316
More from Debian Linux
10.0
CVE-2025-32433
Erlang/OTP SSH Vulnerable to Pre-Authentication RCE
10.0
CVE-2025-24201
Apple Multiple Products WebKit Out-of-Bounds Write Vulnerability
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2026-111497
Out-of-Bounds Write in Google Brotli Decoder
