Medium severity · published Sep 13, 2022
CVE-2022-36107
TYPO3 is an open source PHP based web content management system released under the GNU GPL
5.4
CVSS
0.9%
EPSS
No
On KEV
Description
TYPO3 is an open source PHP based web content management system released under the GNU GPL. It has been discovered that the `FileDumpController` (backend and frontend context) is vulnerable to cross-site scripting when malicious files are displayed using this component. A valid backend user account is needed to exploit this vulnerability. Update to TYPO3 version 7.6.58 ELTS, 8.7.48 ELTS, 9.5.37 ELTS, 10.4.32 or 11.5.16 that fix the problem. There are no known workarounds for this issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.9% · higher than 61% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
TY
Typo3 · Typo3
7.0.0 through 7.6.57; 8.0.0 through 8.7.47; 9.0.0 through 9.5.36; 10.0.0 through 10.4.31; 11.0.0 through 11.5.15 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2022-36107
CVE.org
https://www.cve.org/CVERecord?id=CVE-2022-36107
Patch
https://github.com/TYPO3/typo3/commit/bd58d2ff2eeef89e63ef754a2389597d22622a39
Third Party Advisory
https://github.com/TYPO3/typo3/security/advisories/GHSA-9c6w-55cp-5w25
Vendor Advisory
https://typo3.org/security/advisory/typo3-core-sa-2022-009
More from Typo3
10.0
CVE-2020-11066
In TYPO3 CMS greater than or equal to 9.0.0 and less than 9.5.17 and greater than or equal to 10.0.0 and less than 10.4.2, calling unserialize() on malicious user-submitted…
9.8
CVE-2024-45233
An issue was discovered in powermail extension through 12.3.5 for TYPO3
9.8
CVE-2011-3583
It was found that Typo3 Core versions 4.5.0 - 4.5.5 uses prepared statements that, if the parameter values are not properly replaced, could lead to a SQL Injection vulnerability
9.8
CVE-2011-4628
TYPO3 before 4.3.12, 4.4.x before 4.4.9, and 4.5.x before 4.5.4 allows remote attackers to bypass authentication mechanisms in the backend through a crafted request
8.8
CVE-2025-59017
Broken Access Control in Backend AJAX Routes
