Medium severity · published Sep 21, 2021
CVE-2021-41086
jsuites is an open source collection of common required javascript web components
5.4
CVSS
0.9%
EPSS
No
On KEV
Description
jsuites is an open source collection of common required javascript web components. In affected versions users are subject to cross site scripting (XSS) attacks via clipboard content. jsuites is vulnerable to DOM based XSS if the user can be tricked into copying _anything_ from a malicious and pasting it into the html editor. This is because a part of the clipboard content is directly written to `innerHTML` allowing for javascript injection and thus XSS. Users are advised to update to version 4.9.11 to resolve.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.9% · higher than 60% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
JS
Jsuites · Jsuites
before 4.9.11 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2021-41086
CVE.org
https://www.cve.org/CVERecord?id=CVE-2021-41086
Patch
https://github.com/jsuites/jsuites/commit/d47a6f4e143188dde2742f4cffd313e1068ad3b3
Patch
https://github.com/jsuites/jsuites/commit/fe1d3cc5e339f2f4da8ed1f9f42271fdf9cbd8d2
Third Party Advisory
https://github.com/jsuites/jsuites/security/advisories/GHSA-qh7x-j4v8-qw5w
More from Jsuites
6.1
CVE-2022-25979
Versions of the package jsuites before 5.0.1 are vulnerable to Cross-site Scripting (XSS) due to improper user-input sanitization in the Editor() function
