Medium severity · published Aug 9, 2021
CVE-2021-37633
Discourse is an open source discussion platform
6.1
CVSS
0.8%
EPSS
No
On KEV
Description
Discourse is an open source discussion platform. In versions prior to 2.7.8 rendering of d-popover tooltips can be susceptible to XSS attacks. This vulnerability only affects sites which have modified or disabled Discourse's default Content Security Policy. This issue is patched in the latest `stable` 2.7.8 version of Discourse. As a workaround users may ensure that the Content Security Policy is enabled, and has not been modified in a way which would make it more vulnerable to XSS attacks.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.8% · higher than 55% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DI
Discourse · Discourse
before 2.7.8; 2.8.0; 2.8.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2021-37633
CVE.org
https://www.cve.org/CVERecord?id=CVE-2021-37633
Patch
https://github.com/discourse/discourse/commit/38199424bc840d2ef002cd1e9bffdbb99191eb47
Third Party Advisory
https://github.com/discourse/discourse/security/advisories/GHSA-v3v8-3m5w-pjp9
More from Discourse
9.9
CVE-2025-68662
FinalDestination hostname matching allows SSRF protection bypass
9.8
CVE-2025-53102
Discourse's WebAuthn challenge isn't cleared from user session after authentication
9.8
CVE-2025-48877
Discourse vulnerable to auto-executing of third-party code in embedded CodePen iframe
9.8
CVE-2023-47121
Discourse is an open source platform for community discussion
9.8
CVE-2021-41163
Discourse is an open source platform for community discussion
