Medium severity · published Sep 7, 2021
CVE-2021-32782
Cross-Site Scripting in Nextcloud Circles
5.4
CVSS
0.8%
EPSS
No
On KEV
Description
Nextcloud Circles is an open source social network built for the nextcloud ecosystem. In affected versions the Nextcloud Circles application is vulnerable to a stored Cross-Site Scripting (XSS) vulnerability. Due the strict Content-Security-Policy shipped with Nextcloud, this issue is not exploitable on modern browsers supporting Content-Security-Policy. It is recommended that the Nextcloud Circles application is upgraded to 0.21.3, 0.20.10 or 0.19.14 to resolve this issue. As a workaround users may use a browser that has support for Content-Security-Policy. A notable exemption is Internet Explorer which does not support CSP properly.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.8% · higher than 58% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
SE
security-advisories · nextcloud
< 0.19.1; >= 0.20.0, < 0.20.10; >= 0.21.0, < 0.21.3 · source: vendor
CI
Circles · Nextcloud
before 0.19.14; 0.20.0 before 0.20.10; 0.21.0 before 0.21.3 · source: NVD
Affected product
SE
security-advisories
nextcloud
More from security-advisories
9.8
CVE-2024-22212
Nextcloud global site selector authentication bypass
9.8
CVE-2023-49792
Bruteforce protection can be bypassed with misconfigured proxy
9.8
CVE-2023-48307
Nextcloud Mail app vulnerable to Server-Side Request Forgery
9.8
CVE-2023-48306
Nextcloud Server DNS pin middleware can be tricked into DNS rebinding allowing SSRF
9.8
CVE-2023-32074
Nextcloud user_oidc app is missing brute force protection